Show current status

[Resolved] Google Analytics

Started on December 23, 2020 at 6:18 PM. Resolved after 20 days

Affected

Reporting
Google Analytics API
  • Identified
    December 23, 2020 at 6:18 PM  –  

    The Google Analytics API has been slow to report this week and is continuing to cause delays or gaps in analytics reporting. This is NOT affecting earnings, but is affecting our RPM calculations & the earnings summary in the dashboard.

    To see earnings information, scroll past the Earnings Summary down to the Earnings & RPM section of the dashboard. Earnings will be accurate after 10 am the following day. RPM and Sessions data will not be accurate until Google Analytics reporting is complete. Once the issue has been resolved on Google's end, we will backfill all reporting data.

  • Identified
    January 4, 2021 at 5:35 PM  –  

    Google has acknowledged this problem and is continuing to work on resolving the incident of their API being slow but has not been able to provide a timeline. We're continually monitoring the API performance and pulling data as we can. Once Google has fixed the core problem, we will backfill all data from the outage period.

    In the meantime, please continue using your analytics data from your Google Analytics Dashboard, and if you'd like help calculating your RPM you can reach out to support or calculate your rpm using the following equation: revenue / sessions * 1000

  • Resolved
    January 12, 2021 at 3:20 PM  –  

    The Google Analytics team notified us of a fix in place this morning. We've backfilled all sessions and pageviews data and have reviewed it to be accurate. The earnings summary has been restored and all systems are normal!