All systems operational

Show current status

[Resolved] "Report this ad" button not functioning

Started on March 13, 2021 at 11:40 PM. Resolved after about 1 hour

Affected

"Report this ad" button
  • Investigating
    March 13, 2021 at 11:40 PM  –  

    We are currently investigating this incident and will post more. This not does affect ads or revenue.

  • Resolved
    March 14, 2021 at 1:03 AM  –  

    This issue has been resolved.